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Introduction
Bose ControlSpace Remote Builder Software
Bose ControlSpace Remote (CSR) Builder  software is a graphical user interface tool used to design, test 
and deploy mobile control panels for the Bose CSR client application.
CSR Builder is used by system integrators to configure control panels that are sent to the CSR client 
application. Using control panel templates from within CSR Builder, integrators are able to quickly create 
unique interfaces for wireless control of Bose networked pro audio systems.
System designs created in ControlSpace Designer software are easily imported into CSR Builder. 
Defined system control elements such as volume, mute, source selection, tone EQ, and parameter sets 
are assigned to end-user friendly templates. Multiple application designs—each personalized for a spe-
cific user’s control needs—can be created and tested from CSR Builder and sent wirelessly to mobile 
devices on the network.
You can create control panels either using the built-in templates, or by using the graphical elements 
available in the layout mode to design customized layouts and control buttons.

 l For designing with templates, see Creating Control Panels.

 l For designing customized panels, see Creating Custom Layouts and Creating Custom Controls.

CSR Builder Window Example
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Bose ControlSpace Remote Client 
Bose ControlSpace Remote client application is a mobile device application for Android and iOS devices 
that provides wireless control of networked Bose Professional system components. Personalized for 
each end user’s mobile device, various functions of the system can be adjusted:

 l Volume levels and mute state

 l Source selection

 l Tone EQ settings

 l Parameter set recall

The CSR client application is available as a free download on the App Store or Google Play store.

CSR Client Application Control Panel Example

Getting Started
To get started using the CSR Builder desktop application:

 1. From PRO.BOSE.COM, download and install the CSR Builder desktop application to your com-
puter.

 2. From the Google Play or App Store, download and install the CSR client application to your mobile 
device.

 3. Ensure that your Android or iOS device is connected to the same Wi-Fi network as your Con-
trolSpace/PowerMatch devices.

Trademark Notices
Bose, ControlSpace, and ControlSpace Designer are trademarks of Bose Corporation.
Android™ and Google Play™ are trademarks of Google Inc.
App Store® is a service mark of Apple Inc.
Wi-Fi® is a registered mark of Wi-Fi Alliance.
All other trademarks are the property of their respective owners.
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CSR Builder Window
The CSR Builder window contains four key elements: a menu bar, a toolbar, the Project/Properties panel, 
and the Control Panel canvas.

Menus
The menus located in the menu bar contain the main commands in CSR Builder.

File Menu

The File menu includes the following options:
 l Open CSP File: opens a window for browsing to an existing ControlSpace Designer software pro-

ject file.

 l New Remote app File: opens a window in which you can select a template or blank panel to use 
for building a new Remote app control panel.

 l Open Remote app File: opens a window for browsing to an existing Remote app file.
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 l Save Remote app File: initially opens a window for naming the current Remote app file and 
browsing to a location to save it. Subsequent selections of this menu option will immediately save 
changes directly to the previously selected file location.

 l Save Remote app File As: opens a window for renaming current Remote app file and browsing to 
a location to save it.

 l Update Remove app IP Addresses: opens a window for updating the IP addresses of each device 
in the open project file.

Edit Menu

The Edit menu includes the following options:
 l Undo: erases the last change and reverts to the previous state.

 l Redo: reverts the effects of the undo action.

 l Undo List: opens the Undo/Redo window

 l Cut: removes the selected item and copies it to the clipboard (standard Windows editing func-
tion).

 l Copy: copies the selected item to the clipboard (standard Windows editing function).

 l Paste: pastes the contents of the clipboard (standard Windows editing function).

 l Delete: removes the selected item.
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Layout Menu

The Layout menu includes the following options:
 l Bring to Front: moves the selected object to the top layer.

 l Bring Forward: moves the selected object one layer toward the top.

 l Send to Back: moves the selected object to the bottom layer.

 l Send Backward: moves the selected object one layer toward the bottom.

 l Align Left: aligns selected objects relative to their left edges.

 l Align Right: aligns selected objects relative to their right edges.

 l Align Top: aligns selected objects relative to their top edges.

 l Align Bottom: aligns selected objects relative to their bottom edges.

 l Align Horizontal Center: aligns selected objects relative to their horizontal centers.

 l Align Vertical Center: aligns selected objects relative to their vertical centers.

 l Distribute Horizontally: distributes selected objects evenly along the horizontal axis

 l Distribute Vertically: distributes selected objects evenly along the vertical axis

Tools Menu
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The Tools menu includes the following options:
 l Layout: opens the Layout dialog box, which allows you to add/delete collections and panels.

 l Canvas: opens the Canvas Setup window.

 l Set Exit PIN Code: sets Exit PIN  that allows users to exit the CSR Client application on an MLock-
enabled device. 

 l Go Online: connects to a ControlSpace network.

 l Send to Mobile Device: transmits the control panel file to a mobile device.

 l Level: specifies the appearance of the Level control as a slider or a button:

 l Meter: specifies  the appearance of the Meter control as a meter bar or an icon:

 

Help Menu

The Help menu includes the following options:
 l Help Topics: Opens User Help.

 l About ControlSpace Remote Builder: opens a dialog box that displays the software version num-
ber.

 Toolbar
The toolbar contains icons/buttons that provide the following functions: 

Open CSP file: Opens a window for browsing to an existing ControlSpace Designer software 
project file

New Remote app File: Opens a window in which you can select a template or blank panel to 
use for building a new Remote app control panel
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Open Remote app File: Opens a window for browsing to an existing Remote app file

Save Remote app File: Initially opens a window for naming the current Remote app file and 
browsing to a location to save it. Subsequent selections of this tool will immediately save 
changes directly to the previously selected file location

Cut

Copy

Paste

Delete

Undo

Redo

Undo List: Opens Undo list window

Edit Mode: Enables/disables Edit mode

Layout: Opens "Layout Tool" on page 11

Canvas: Opens "Canvas Setup Properties" on the next page

Go Online

Send to Mobile Device: Sends file to mobile device

Project/Properties Panel
Selecting the Project tab displays a tree view of devices and controls in the opened project file. Select-
ing the Properties tab displays properties for a selected object on the canvas.

 Control Panel Canvas
This canvas is the workspace for creating control panels. The size, shape, orientation, and other prop-
erties of the Canvas is set using the Canvas Setup Properties tool in the toolbar.
See "Canvas Setup Properties" on the next page for more details.
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Canvas Setup Properties
The Canvas Setup window allows you to define the size and features of the control panel you are cre-
ating.

Canvas Setup window

The Canvas Setup window includes the following properties:
 l Device: Determines the canvas Size and Aspect Ratio for the selected device. The drop-down 

menu includes several pre-populated options, as well as any devices added using the Custom 
Device List button (described later in this topic). The User Defined option allows you to set values 
such as size and aspect ratio manually.

Note: Size and Aspect Ratio can only be adjusted manually when User Defined is selected as the 
device.

 l Size: Diagonal screen dimension of the selected device.

 l Units: Specifies whether the measurement unit in the Size field is in inches or centimeters. This 
option appears on the right side of the window.

 l Aspect Ratio: The proportional relationship between the width and height of the screen on the 
selected device.

 l Orientation: Changes the orientation of the screen between portrait and landscape.

 l Top Slot/Bottom Slot: Places the Standard Toolbar, Minimum Toolbar, Status bar, or no toolbar 
(None) in the top/bottom border of the canvas.

 -  Standard Toolbar: The left side of the Standard Toolbar includes the name of the site where 
the panel will be used. You can edit the site name in the Layout window. The right side of the 
toolbar includes an Online/Offline link indicator and a Setup information button.

 -  Minimum Toolbar: This toolbar includes the Online/Offline link indicator and the Setup inform-
ation button.

 -  Statusbar: The Statusbar indicates which collection of panels has been selected. The dots indic-
ate how many panels are in the collection (there is always one blank panel). Click the left/right 

CSR Builder 3.0 User Guide

- 8 -



arrows to view other panels – the highlighted dot will move left/right accordingly. If multiple 
collections exist, you can click COLLECTION to open a list of panel collections and select a dif-
ferent one.

 -  None: Removes the toolbar from the canvas.

 
Example: The following image shows the Standard Toolbar specified for the Top Slot of the can-
vas and Statusbar specified for the Bottom Slot of the canvas:

 l Skin: Selects a light or dark skin for the panel.

 l Accent: Selects an accent color (Black, Blue, Green, Pink, Red, or Yellow) for the controls dragged 
into the panel.

 l Center Controls Horizontally: When this check box is selected, the controls are centered in the 
workspace. This applies only when creating custom control panels.

 l Units: Specifies units of measurement as either inches or centimeters.

 l Customize Device List: This button appears on the right side of the Canvas Setup window and 
opens the Custom Device List dialog box, in which you can create device definitions other than 
those in the Device drop-down menu. 
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Custom Device List dialog box
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Layout Tool
The Layout tool manages the collections and control panels being created in CSR Builder. By default, the 
Layout tool provides one collection (COLLECTION1) with one blank panel (Home). You can add addi-
tional blank panels from the template list to create custom layouts.

Default Layout tool content

The Layout tool provides the following control buttons:
 l OK: Stores changes and closes the tool.

 l Cancel: Closes the tool without making any changes.

 l Add Collection: Adds another collection to the list.

 l Delete Collection: Removes the selected collection from the list.

 l Add Panel: Adds another control panel to the list

 l Delete Panel: Removes the selected control panel from the list

 l Move Up: Moves the selected item up one line in the list.

 l Move Down: Moves the selected item down one line in the list.

 l Edit Title: Allows changing the title of the selected collection or control panel.
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File Types
The CSR Builder application is compatible with the following file types:

File 
Type Description

.csp ControlSpace Designer project file.

.cpf Custom control panel file.

.cpz A packaged file that includes data from a control panel file (.cpf) and its associated ControlSpace 
Designer project file (.csp).

 
 

Controls
When a ControlSpace Designer project file is opened in CSR Builder. All of the devices in that design 
appear in the  Project/Properties panel (the left pane), along with the signal processing blocks that are 
programmed in each device. 
Controls are the parameters within each  signal processing block (module) that you can assign to a con-
trol panel so that they can be controlled with a mobile device running the CSR client application. 
For example, the image below shows the following Input/Output controls:

 l Level: Allows the remote user to adjust the volume level.

 l Mute: Allows the remote user to control the Mute On/Off state.

 l Dialer:  (PSTN and VoIP inputs only) Allows the remote user to dial numbers/initiate calls, and 
answer calls with the mobile device.

 l Meter: Allows the remote user view input/output signal strength.
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Creating Panels Using Templates
Creating Control Panels

 1. Open the CSR Builder application on your computer using the desktop icon.

 2. In the CSR Builder window, click the Open CSP File tool.

 3. In the Open ControlSpace Designer File window, select a ControlSpace Designer (CSD) project 
file  and click Open.

 4. Ensure that all of the devices and controls in the CSD project are listed in the CSR Builder window.
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 5. Before you begin creating a control panel, ensure that Edit mode is selected. 

Note: Edit mode must be enabled in order to create a control panel.

 6. In the toolbar, click the Canvas tool. Make your selections and click OK.

Note: See "Canvas Setup Properties" on page 8 for more information.
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 7. In the toolbar, click the Layout tool.

 8. In the Layout window, add a template to the workspace. Click Home under COLLECTION1, and 
then click Add Panel.
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 9. In the Select a Template window, select a template, and then click OK. In the Layout window, click 
OK. The selected template now appears in the workspace.

 10. Drag controls to the predefined locations on the control panel template (see the following 
examples).

Notes:
 l For more information about controls, see the Project Controls topic in this guide.

 l To verify the operation of any control panel feature such as a slider or drop list, be sure to disable 
Edit mode.
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Dragging a Source list to the Drop List

Dragging a list of Parameter Sets to the Drop List
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Dragging a Parameter Set List to the Drop List

Dragging the Group Volume Gain to the slider

 11. To change volume limits on a slider, select the slider and click the Properties tab. Within this pane 
you can set minimum and maximum limits, and select Percent or dB for units.
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Volume Properties

 12. To add another panel, click the Layout button, select COLLECTION1, and then click Add Panel.

Locating the Add Panel button

 13. Select a panel template and click OK. Repeat this procedure to add as many panels as needed. 
Click the left and right arrows in the Status bar to scroll through the panels.
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Adding another panel template to the Layout

COLLECTION1 with one blank panel and two templates

Note: To change the collection name, select COLLECTION1 and click Edit Title. Enter the new 
name and click OK.
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Changing name of COLLECTION1

 14. To add another collection, select COLLECTION1 again and click Add Collection. COLLECTION2 is 
added to the Layout.

Adding a collection

 15. To create more panels, add more templates or blank panels and drag-and-drop controls to them.

 16. When you are done, click Save Remote app File.

Save Remote app File button
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Sending to a Mobile Device
To send a panel to your mobile device, make sure your PC and mobile device are connected to the same 
Wi-Fi router.

 1. Open the CSR client app on your mobile device.

 2. Touch the Settings icon.

Remote App Settings icon

 3. In the pop-up menu, touch Receive.

Selecting Receive in the Remote app

The Receive Control Panel dialog box appears and reveals the IP address that you will use in Step 
5.
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Receive Control Panel Dialog Box

 4. On your computer, in the CSR Builder toolbar, click the Send to Mobile Device icon.

Send to Mobile Device

 5. In the Send to Mobile Device dialog box, enter the IP address from the Receive Control Panel dia-
log box on the mobile device and click OK.
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The control panel file will be transferred to the mobile device.
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Creating Custom Panels
Creating Custom Layouts
You can create custom control panels by using the tools and options available in CSR Builder. From the 
Project tab, you can combine labels, images, frames, and regions to create a custom layout. The Layout 
menu functions can help you position the objects you placed on the canvas.

Importing Backgrounds
You can import backgrounds to place maps, floor plans, or other images of a venue onto the canvas.

To place a floor plan or map on the canvas:
 1. On the Project tab, expand the Graphics group.

 2. Drag the Image icon onto the canvas.
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 3. In the canvas, double-click the Image icon. The Properties tab will automatically be selected.

 4. On the Properties tab, locate the file you want to import from your computer and click Open. The 
file will appear on the canvas.

 5. Re-size the image by dragging the handles on the right side and bottom of the image frame. 
Alternatively, set the image as a background image by selecting the Use as background image 
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check box and adjusting the available parameters, which are listed below.

 l Mode: Specify how to adjust the background image size with respect to the canvas. Options 
include:

 -  Stretch: Fits the width and height of the image to match the canvas size. This option does not 
preserve the aspect ratio of the original image.

 -  Preserve aspect and fit: Fits the larger image dimension to the canvas size, while preserving 
the aspect ratio of the original image.

 -  Preserve aspect and crop: Fits the smaller image dimension to the canvas size, while pre-
serving the aspect ratio of the original image.

 -  Tile: Repeats the image horizontally and vertically to fill the canvas. This option preserves the 
size and aspect ratio of the original image.

 -  Tile Vertically: Fits the image width to the canvas size, then repeats the image vertically to fill 
the canvas. This option does not preserve the aspect ratio of the original image.

 -  Tile Horizontally: Fits the image height to the canvas size, then repeats the image horizontally 
to fill the canvas. This option does not preserve the aspect ration of the original image.

 -  Pad: Centers the image on the canvas. This option preserves the aspect ratio of the original 
image.

 l Opacity: Use the slider to adjust the opacity of the background image.

 l Maximum cached width: Set the maximum cache width used for the background image. Larger 
cache size allows for higher-resolution images, but may have a longer load time. Smaller cache 
size may allow image to load faster, but display with a lower resolution.

Adding images
CSR Builder software includes an image library of sources and zones that may be used to create your 
custom control panel. Library images are available in five colors: Blue, Green, Pink., Red, and Yellow.
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Source Image Library
 

Zone Image Library

To place a library image on the canvas, 
 1. Follow Steps 1-3 of the Importing Backgrounds procedure (above) and drag the image icon into 

the canvas.
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 2. On the Properties tab, navigate to the directory for the Sources and Zones folders.

 3. Open the folder that corresponds with the color you wish to use. 
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 4. Select an image and click Open. The image will appear on the canvas.

Note: Image colors match the skin accent colors selected in the Canvas Setup properties.

 5. Re-size the image by dragging the handles on the right and bottom edges of the image frame.

Adding Text Frames & Labels
Use the Label option in the Graphics group to  place a text field on other graphics and create labels or 
text strings. Resize labels by dragging the handles on the right and bottom edges of the frame.

Double-click the label in the canvas or click the Properties tab to display the label properties.
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Label properties include the following parameters:
 l X/Y: Specifies the X/Y coordinates of the upper-left corner of the label.

 l Width/Height: Specifies the width and height of the label.

 l Text: Provides an area in which to enter text for the label.

 l Align: Positions the text left, right, or center.

 l Scale: Changes the size of the text.

 l Color: Changes the color of the text.

Adding a Frame
Use the Frame option in the Graphics group to  add a rectangular shape to your design. Resize frames by 
dragging the handles on the right and bottom edges of the frame.
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Double-click the frame in the canvas or click the Properties tab to reveal the frame properties.

Frame properties  include the following parameters:
 l X/Y: Specifies the X/Y coordinates of the upper-left corner of the frame.

 l Width/Height: Specifies the width and height of the frame.

 l Field Color: Changes the fill color.

 l Border Color: Changes the color of the border.

 l Border Width: Changes the line weight of the border.

Adding a Region
Use the Region option in the Graphics group to add a customizable polygon to the canvas. A region can 
be linked to an existing control panel. Reshape regions by dragging the handles on the edges of the 
frame. To add another handle, press and hold the Ctrl key, place the cursor where you want the handle, 
and then click the mouse button. To remove a handle, press and hold Ctrl+Shift, and then click the 
handle you want to remove.
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Double-click the region in the canvas or click the Properties tab to reveal the region properties.

Region properties  include the following parameters:
 l X/Y: Specifies the X/Y coordinates of the upper-left corner of the region.

 l Width/Height: Specifies the width and height of the region.

 l Field Color: Changes the fill color.

 l Border Color: Changes the color of the border.

 l Border Width: Changes the line weight of the border.

 l Path: Links the region to an existing control panel.
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Creating Custom Controls
Project controls listed in the tree view can be dragged into a custom panel design. The appearance of 
buttons, sliders, and drop-lists can be changed using their individual properties.

Custom Buttons
 1. From the Project tab, drag a button into the canvas.

 2. Using the handles on the right and bottom edges, resize the button.

 3. To access the button properties, double-click the button or click the Properties tab.

 4. Adjust the properties as desired, using the options available in the tabs:
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 l Main tab:

 -  X/Y: X/Y coordinates of the upper-left corner of the frame.

 -  Width/Height: width and height of the button.

 -  Mode: selects how the button appears: Text, Image, or Text+Image (both).

 -  Border: when checked, places a border around the button.

 l Text tab (only active in Text and Text+Image modes):

 -  Text: allows text entry for button labels when mute is off or on.

 l Images tab: (only active in Image and Text+Image modes)

 -  Image: specifies whether to use the default icon or a custom image.

 -  Off: specifies image when mute is off.

 -  On: specifies image when mute is on.

Custom Sliders
 1. From the Project tab, drag a slider into the canvas.

 2. Using the handles on the right and bottom edges, re-size the slider.

 3. To access the slider properties, double-click the slider or click the Properties tab.
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 4. Adjust the properties as desired:

 -  X/Y: X/Y coordinates of the upper-left corner of the frame.

 -  Width/Height: width and height of the slider.

 -  Max: selects the maximum value on the slider.

 -  Min: selects the minimum value on the slider.

 -  Vertical/Horizontal: sets the orientation of the slider as vertical or horizontal.

 -  Units: specifies dB or Percent for volume measurement.

 -  Color: selects the color of the slider.

 -  Text: allows entry of a label for the slider.

Custom Drop-lists
 1. From the Project tab, drag a list into the canvas.

 2. Select the items you want in the list and click OK.
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 3. Using the handles on the right and bottom edges, resize the drop list.

 4. To access the drop-list properties, double-click the list or click the Properties tab.

 5. Adjust the properties as desired:
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 -  X/Y: X/Y coordinates of the upper-left corner of the frame.

 -  Width/Height: width and height of the slider.

 -  Align: positions the list Left, Center, or Right

 -  Border: when checked, places a border around the button.

Custom RCGroups
 1. In the Project tab, expand the device with the desired room controls. Drag the desired control(s) 

for one of the rooms onto the canvas. (Controls for standard room combiner blocks [StRC] will be 
under the Blocks item for the device.)

 2. Create an additional panel for each room you want to add:
 1. Click the Layout icon in the toolbar, or click Tools > Layout.

 2. In the Layout window, select the desired collection, and then click Add Panel.

 3. In the Select a Template window, select Blank Panel, and then click OK.

 4. In the Layout window,  click OK. Below the canvas, there should be an additional dot in the 
Status bar to indicate a new panel.

 5. In the Project tab, expand the device with the desired room controls. Drag the desired con-
trol(s) for one of the rooms onto the canvas.

 3. Repeat Step 2 to create a separate panel for your room-combining controls.

 4. On the Project tab, expand the RCGroups item, and then expand the RCGroup with the desired 
rooms.

 5. Drag the Combination Control for the RCGroup onto the canvas. This is the selector for each 
room combination.

 6. Drag the desired control(s) for each room you created in Steps 1–2 onto the canvas.
 l Room Name: the name of the room in the RCGroup.

 l Active Combination: a field that shows the names of the other rooms in the combination.

 l Room Layout: an adjustable polygon representing the layout of the room. Drag a handle on 
the edge of the layout to move it. Press and hold the Ctrl key and click an edge of the poly-
gon to add another handle at that location. Press and hold Ctrl+Shift and click a handle to 
remove it.

 7. To access the properties of an item in any of the panels, double-click the item or click the Prop-
erties tab. Adjust the properties as desired.

RCGroup items include the following properties:
 l RCGroup Name: the properties are identical to those of a label (see Adding Text Frames 

& Labels in Creating Custom Layouts).

 l Combination Control:

 -  Y: the Y coordinate of the upper-left corner of the selector frame.

 -  Height: the height of the selector frame.

 -  Side Margins: the width of the margin on either side of the selector frame.

 l Room Name: the properties are identical to those of a label (see Adding Text Frames & Labels 
in Creating Custom Layouts).

 l Active Combination: 

 -  Y: the Y coordinate of the upper-left corner of the frame.

 -  Height: the height of the frame.

 -  Side Margins: the width of the margin on either side of the frame.

 -  Color: the color of the text inside of the frame.
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 -  Border Color: the color of the border of the frame.

 -  Border Width: the width of the border of the frame.

 -  Separator: the character(s) that separate the combined room names shown in the frame.

 l Room Layout:

 -  X/Y: X/Y coordinates of the upper-left corner of the region.

 -  Width/Height: width and height of the region.

 -  Opacity: the opacity of the region.

 -  Border Color: the color of the border of the region.

 -  Border Width: the width of the border of the region.

Other controls are described elsewhere in this help topic: Custom Buttons, Custom Sliders, Custom 
Drop-lists, Custom Parameter Sets, Custom Parameter Set Lists, Custom Links, Custom Setup Button, 
or Custom Remote Connection Indicator.

Custom Parameter Sets
 1. From the Project tab, expand ParameterSets and drag a parameter set onto the canvas.

 2. Using the handles on the right and bottom edges, resize the button.
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 3. To access the properties, double-click the button or click the Properties tab.

 l Adjust the properties as desired:

 -  X/Y: X/Y coordinates of the upper-left corner of the frame.

 -  Width/Height: width and height of the button.

 -  Mode: selects how the button appears: text, or text+image.

 -  Border: when checked, places a border around the button.

 -  Text: in Text mode, allows text entry for a button label.

 -  On/Off: in Image mode, allows an image selection for both on/off states of the button.

Custom Parameter Set Lists
 1. From the Project tab,  expand ParameterSetLists and drag a parameter set list onto the canvas.

 2. Using the handles on the right and bottom edges, resize the button.

 3. To access the properties, double-click the button or click the Properties tab.

 4. Adjust the properties as desired:

 -  X/Y: X/Y coordinates of the upper-left corner of the frame.

 -  Width/Height: width and height of the button.

 -  Align: selects the horizontal alignment of the text in the button.

 -  Border: when checked, places a border around the button.

Custom Links
 1. From the Project tab, expand Links, expand a collection, and then drag a control panel onto the 

canvas.
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 2. Using the handles on the right and bottom edges, re-size the button.

 3. To access the properties, double-click the button or click the Properties tab.

 4. Adjust the properties as desired:

 -  X/Y: X/Y coordinates of the upper-left corner of the frame.

 -  Width/Height: width and height of the button.

 -  Mode: selects how the button appears: text or image.

 -  Border: when checked, places a border around the button.

 -  Text: in Text mode, allows text entry for a button label.
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 -  Image: in Image mode, allows selection of an image to use on the button.

 -  Path: links the button to an existing control panel.

Custom Setup Button
 1. From the Project tab, expand System, and then drag a Setup Button onto the canvas.

 2. Using the handles on the right and bottom edges, resize the button.

 3. To access the properties, double-click the button or click the Properties tab.

Adjust the properties as desired, using the options available in the tabs:
 l Main tab:
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 -  X/Y: X/Y coordinates of the upper-left corner of the frame.

 -  Width/Height: width and height of the button.

 -  Mode: selects how the button appears: Text, Image, or Text+Image (both).

 -  Border: when checked, places a border around the button.

 l Text tab (only active in Text and Text+Image modes):

 -  Text: allows text entry for a button label.

 l Images tab (only active in Image and Text+Image modes):

 -  Image: specifies whether to use the default icon or a custom image. If you select Custom, loc-
ate the desired image by using the field that appears below the drop-down menu.

Custom Remote Connection Indicator
 1. From the Project tab, drag a connection indicator button from System onto the canvas.

 2. Using the handles on the right and bottom edges, resize the button.
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 3. To access the properties, double-click the button or click the Properties tab.

 4. Adjust the properties as desired, using the options available in the tabs:
 l Main tab:

 -  X/Y: X/Y coordinates of the upper-left corner of the frame.

 -  Width/Height: width and height of the button.

 -  Mode: selects how the button appears: Text, Image, or Text+Image (both).

 -  Border: when checked, places a border around the button.

 l Text tab (only active in Text and Text+Image modes): 

 -  Text: allows text entry for button labels when the connection is off, on, or partial.

 l Images tab (only active in Image and Text+Image modes): 

 -  Image: specifies whether to use the default icon or a custom image.

 -  Off: specifies image when the remote connection is off.

 -  On: specifies image when the remote connection is on.

 -  Partial: specifies image when the remote connection is partially active.
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Setting an Exit PIN for MLock-Enabled Devices
By default, users are unable to exit the CSR Client application on certain Android devices that are 
MLock-enabled.
MLock is a preinstalled application, developed by Mimo Monitors, that “locks down” a Mimo Android 
device by securely disabling physical buttons and the touchscreen. MLock places the device in Kiosk 
mode to restrict functionality, including the ability to exit the application.
You can set an Exit PIN in CSR Builder , and then provide that PIN to users to allow them to exit the CSR 
Client application on an MLock-enabled device. Users will be prompted to enter the PIN when they 
select Exit from the Setup menu:

To Set an Exit PIN in CSR Builder :
 1. From the Tools menu, select Set Exit PIN Code.
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 2. In the Set Exit PIN Code dialog box, enter a PIN, and then click OK to save it.

Note: The PIN must be numbers only (no letters or symbols), with a maximum length of 25 digits.

Note: If you leave the PIN Code field blank, all users will be able to exit the application without 
being prompted for a PIN.

 3. Save the CSR Builder  project file and send it to the mobile device.

 4. Provide the PIN to any users to whom you want to provide the ability to exit the CSR Client applic-
ation. 

Note: The PIN code is empty in projects created in CSR Builder  version 2.8 or previous.

CSR Builder 3.0 User Guide

- 46 -

../../../../../Content/Sending_to_Mobile_Device.htm

	Introduction
	Bose ControlSpace Remote Builder Software
	Bose ControlSpace Remote Client
	Getting Started
	Trademark Notices


	CSR Builder Window
	Menus
	File Menu
	Edit Menu
	Layout Menu
	Tools Menu
	Help Menu

	Toolbar
	Project/Properties Panel
	Control Panel Canvas

	Canvas Setup Properties
	Layout Tool
	File Types
	Controls

	Creating Panels Using Templates
	Creating Control Panels
	Sending to a Mobile Device

	Creating Custom Panels
	Creating Custom Layouts
	Importing Backgrounds
	To place a floor plan or map on the canvas:

	Adding images
	To place a library image on the canvas,

	Adding Text Frames & Labels
	Adding a Frame
	Adding a Region

	Creating Custom Controls
	Custom Buttons
	Custom Sliders
	Custom Drop-lists
	Custom RCGroups
	Custom Parameter Sets
	Custom Parameter Set Lists
	Custom Links
	Custom Setup Button
	Custom Remote Connection Indicator


	Setting an Exit PIN for MLock-Enabled Devices
	To Set an Exit PIN in CSR Builder :


