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Introduction
Product Overview
Bose® ControlSpace® Remote builder software
Bose ControlSpace Remote builder software is a graphical user interface tool used to design, test and deploy 
mobile control panels for the Bose ControlSpace Remote app.

Bose ControlSpace Remote builder is used by system integrators to configure control panels that are sent to 
the ControlSpace Remote app. Using control panel templates from within ControlSpace Remote builder, 
integrators are able to quickly create unique interfaces for wireless control of Bose networked pro audio sys-
tems.

System designs created in ControlSpace Designer™ software are easily imported into ControlSpace Remote 
builder. Defined system control elements such as volume, mute, source selection, tone EQ, and parameter 
sets are assigned to end-user friendly templates. Multiple app designs – each personalized for a specific 
user’s control needs – can be created and tested from ControlSpace Remote builder and sent wirelessly to 
mobile devices on the network.

You can create control panels either using the built-in templates, or using the graphical elements available in 
the layout mode to design customized layouts and control buttons.

For designing with templates, see "Creating Control Panels" on page 15.

For designing customized panels, see "Creating Custom Layouts" on page 26 and "Creating Custom Controls" 
on page 37.

ControlSpace Remote Builder Window Example
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Bose ControlSpace Remote app
Bose ControlSpace Remote app is a mobile device application for Android™ and iOS devices that provides 
wireless control of networked Bose Professional system components. Personalized for each end user’s 
mobile device, various functions of the system can be adjusted:

• Volume levels and mute state

• Source selection

• Tone EQ settings

• Parameter set recall

ControlSpace Remote app is available as a free download on the App Store or Google Play™ store.

ControlSpace Remote App Control Panel Example

To get started
1. From pro.Bose.com, download and install the ControlSpace Remote builder desktop app to your com-

puter.

2. From the Google Play™ or App Store, download and install the ControlSpace Remote app to your mobile 
device.

3. Ensure that your Android™ or iOS device is connected to the same Wi-Fi® network as your Con-
trolSpace/PowerMatch devices.

 

Android and Google Play are trademarks of Google Inc.

App Store is a service mark of Apple Inc.

Wi-Fi is a registered mark of the Wi-Fi Alliance.
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Remote Builder Window

Remote builder window elements

 Menus

File Menu

Open CSP file… opens a window for browsing to an existing ControlSpace® Designer™ software project 
file.

New Remote app File… opens a window in which you can select a template or blank panel to use for build-
ing a new Remote app control panel.

Open Remote app File… opens a window for browsing to an existing Remote app file.

Save Remote app File… initially opens a window for naming the current Remote app file and browsing to 
a location to save it. Subsequent selections of this menu option will immediately save changes directly to the 
previously selected file location.
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Save Remote app File As… opens a window for renaming current Remote app file and browsing to a loc-
ation to save it.

Update Remove app IP Addresses... opens a window for updating the IP addresses of each device in the 
open project file.

Edit Menu

Undo… erases the last change and reverts to the previous state.

Redo… reverts the effects of the undo action.

Undo List… opens the Undo/Redo window

Cut… removes the selected item and copies it to the clipboard (standard Windows editing function).

Copy… copies the selected item to the clipboard (standard Windows editing function).

Paste… pastes the contents of the clipboard (standard Windows editing function).

Delete… removes the selected item.

Layout Menu

Bring to Front… moves the selected object to the top layer.

Bring Forward… moves the selected object one layer toward the top.

Send to Back… moves the selected object to the bottom layer.

Send Backward… moves the selected object one layer toward the bottom.

Align Left… aligns selected objects relative to their left edges.

Align Right… aligns selected objects relative to their right edges.
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Align Top… aligns selected objects relative to their top edges.

Align Bottom… aligns selected objects relative to their bottom edges.

Align Horizontal Center… aligns selected objects relative to their horizontal centers.

Align Vertical Center… aligns selected objects relative to their vertical centers.

Distribute Horizontally… distributes selected objects evenly along the horizontal axis

Distribute Vertically… distributes selected objects evenly along the vertical axis

Tools Menu

Layout… opens the Layout dialog which allows you to add/delete collections and panels.

Canvas… opens the canvas setup dialog.

Go Online… connects to a ControlSpace network.

Send to Mobile Device… transmits the control panel file to a mobile device.

Help Menu

Help Topics… Opens online Help.

About ControlSpace Remote builder… opens a dialog which reveals the software version number.

 Toolbar

Open CSP file - Opens a window for browsing to an existing ControlSpace® Designer™ software project 
file

New Remote app file - Opens a window in which you can select a template or blank panel to use for 
building a new Remote app control panel

Open Remote app file - Opens a window for browsing to an existing Remote app file

Save Remote app file - Initially opens a window for naming the current Remote app file and browsing to 
a location to save it. Subsequent selections of this tool will immediately save changes directly to the 
previously selected file location

Cut

Copy

Paste
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Delete

Undo

Redo

Opens Undo list window

Enables/disables Edit mode

Opens "Layout Tool" on page 13

Opens "Canvas Setup Properties" below

Go Online

Sends file to mobile device

 

 Project/Properties Panel
Selecting the Project tab displays a tree view of devices and controls in the opened project file. Selecting 
the Properties tab displays properties for a selected object on the canvas.

 Control Panel Canvas
This canvas is the workspace for creating control panels. The size, shape, orientation, and other properties 
of the Canvas is set using the Canvas Setup properties tool in the toolbar.

See "Canvas Setup Properties" below for more details.

Canvas Setup Properties
The Canvas Setup window allows you to define the size and features of the control panel you are creating.
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The Canvas Setup includes the following properties:

Device – Determines the canvas Size and Aspect Ratio for the selected device. The drop-down menu 
includes several pre-populated options, as well as an devices added using the Custom Device List. The User 
Defined option allows you to set values such as size and aspect ratio manually.

NOTE: Size and Aspect Ratio can only be adjusted manually when "User Defined" is selected as 
the device.

Size – Diagonal screen dimension of the selected device. The minimum allowed size is 4 inches (10.15 cm), 
and the maximum allowed size is 24 inches (60.97 cm).

Aspect Ratio – The proportional relationship between the width and height of the screen on the selected 
device.

Orientation – Changes the orientation of the screen between portrait and landscape.

Top Slot/Bottom Slot – Places the Standard Toolbar, Minimum Toolbar, Statusbar, or no toolbar (None) in 
the top/bottom border of the Canvas.

Standard Toolbar: The left-hand end of the toolbar has a field for naming the site where the panel will 
be used. The SITE NAME is entered using the Layout setup window. The right-hand end of the toolbar 
includes an Online/Offline link indicator and a setup information button.

Minimum Toolbar: The Minimum Toolbar only has the Online/Offline link indicator and the setup inform-
ation button.

Statusbar: The Statusbar indicates which collection of panels has been selected. The dots indicate how 
many panels are in the collection (there is always one blank panel). Click the left/right arrows to view 
other panels – the highlighted dot will move left/right accordingly. Click on "COLLECTION" to open a list 
of panel collections and select a different one.
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Skin – Selects a Light or Dark Skin for the panel.

Accent – Selects an accent color (Black, Blue, Green, Pink, Red, or Yellow) for the controls dragged into the 
panel.

Center Controls Horizontally – When checked, centers controls in the workspace. Applies only when cre-
ating custom control panels.

Units - Selects units as either inches or centimeters.
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Customize Device List - Opens the Custom Device List window.

 

 

Device List - Lists the custom devices specified in the file.

Create Device Definition - Specifies the Name and the Diagonal Length of the custom device. The 
minimum allowed diagonal length size is 4 inches (10.15 cm), and the maximum allowed size is 24 
inches (60.97 cm).

Portrait Aspect Ratio - Sets the Height and Width of the device display. These values do not 
have units because they are only used to calculate the portrait aspect ratio. The portrait aspect ratio 
(Ratio) is automatically calculated from the specified height and width. This value must be greater 
than or equal to 1.

Add - Adds the new device to the Device List. This button becomes active when all of the necessary 
fields are specified.

Delete Selected - Deletes the custom device selected in the Device List.

Move Up - Moves the selected custom device up in the Device List.

Move Down - Moves the selected custom device down in the Device List.

Save to External File - Saves the parameters of the selected custom device as an external .TXT file.

Load From External File - Loads a custom device from an external .TXT file.

Ignore duplicates - When this box is checked, Builder ignores duplicates entries loaded into the Device 
List from external files.

Save - Saves any changes made to the Device List and the selected device.

Close - Closes the Custom Device List window.
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Layout Tool
The Layout tool manages the collections and control panels being created in ControlSpace® Remote builder 
software. Initially, the Layout tool always provides one collection (COLLECTION1) with one blank panel 
(Home). For creating custom layouts you can add additional blank panels from the template list.

Initial Layout tool content

The Layout tool provides the following control buttons:

OK – Stores changes made and closes the tool.

Cancel – Closes the tool without making any changes.

Add Collection – Adds another collection to the list.

Delete Collection – Removes the selected collection from the list.

Add Panel – Adds another control panel to the list

Delete Panel – Removes the selected control panel from the list

Move Up – Moves the selected item up one line in the list.

Move Down – Moves the selected item down one line in the list.

Edit Title – Allows changing the title of the selected collection or control panel.
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File Types
This application is compatible with the following file types.

File 
Type Description

.csp ControlSpace® Designer™ project file.

.cpf Custom control panel file.

.cpz A packaged file that includes data from a control panel file (.cpf) and its associated ControlSpace 
Designer project file (.csp).
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Creating Panels Using Templates
Creating Control Panels
1. Open the Remote builder app on your computer using the desktop icon.

2. In the Remote builder Window, click the Open CSP File tool.

Open CSP File tool

3. From the dialog window, select the ControlSpace Designer project file you created and click Open.

Selecting a Project File
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4. Check that all the devices and controls in that project are listed in the window.

Project File Devices and Controls

5. Before you start creating a control panel, make sure the Edit mode is selected. 

NOTE: The Edit mode must be enabled in order to create a control panel.

Edit Mode Selected
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6. In the toolbar, click the Canvas Setup tool. Make your selections and click OK.

NOTE: See "Canvas Setup Properties" on page 9 for more information.

Selecting canvas size for your device

7. In the toolbar, click the Layout tool.

Clicking the Layout tool
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8. Using the Layout window, add a template to the workspace. For example, click Home below 
COLLECTION1. Click Add Panel, select a template and click OK. 

Selecting a control panel template

 

Placing the template in the workspace
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9. Drag controls to the pre-defined locations on the control panel template. See the following examples.

NOTE: To verify the operation of any control panel feature such as a slider or drop list, be 
sure to disable the Edit mode.

Dragging a Source list to the Drop List

Dragging a Parameter Set List to the Drop List
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Dragging the group volume gain to the slider

To change volume limits on a slider, select the slider and click the properties tab. In this pane you can 
set the maximum and minimum limits and select Percent or dB for units.

Volume Properties
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10. To add another panel, click the Layout button, select COLLECTION1 and click Add Panel.

Locating the Add Panel button

11. Select a panel template and click OK. Repeat this to add as many panels as needed. Click the left and 
right arrows in the Status bar to scroll through the panels.

Adding another panel template to the Layout
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COLLECTION1 with one blank panel and two templates

NOTE: To change the COLLECTION Name, select COLLECTION1 and click Edit Title. Enter the 
new name and click OK.

Changing Name of COLLECTION1.
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12. To add another collection, select COLLECTION1 again and click Add Collection. COLLECTION2 is 
added to the Layout.

13. To create more panels, add more templates or blank panels and drag-and-drop controls to them.

14. When you are done, click Save Remote app File.

Save Remote app File button

Sending to a Mobile Device
To send a panel to your mobile device, make sure your PC and mobile device are connected to the same 
Wi-Fi® router.

1. Launch the Remote app on your mobile device.

2. Touch the Settings icon.

Remote App Settings icon
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3. In the pop-up menu, touch Receive.

Selecting Receive in the Remote app

The Receive Control Panel dialog appears and reveals the IP address used in Step 5.

Receive Control Panel Dialog
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4. On your computer in the Remote builder window toolbar, click the Send to Mobile Device icon.

5. In the Send to Mobile Device dialog box, enter the IP address shown in the Receive Control Panel dialog 
on the mobile device and click OK.

The control panel file will be transferred to the mobile device.
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Creating Custom Panels
Creating Custom Layouts
Using the tools and options available in ControlSpace® Remote builder you can create your own customized 
control panels. From the Project tab you can combine labels, images, frames, and regions to create a cus-
tomized layout. The Layout menu functions can help you position the objects you placed on the canvas.

Locating Graphics

Importing backgrounds
Placing map, floor plan, or other graphic of a venue in the workspace.

To place a floor plan or map on the canvas:

1. In the Project tab, expand the Graphics group.
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2. Drag the Image icon into the canvas.

Dragging Image icon into the Canvas

3. In the canvas, double click the Image icon. The Properties tab will automatically be selected.

4. In the Properties tab, navigate to the file you want to import from your computer and click Open. The 
file will appear on the canvas.

Searching for an Image
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5. Re-size the image by dragging the handles on the right side and bottom of the image frame. Altern-
atively, set the image as a background image by clicking "Use as background image" and adjusting the 
available parameters.

Mode - Specify how to adjust the background image size with respect to the canvas. Options include:

Stretch: Fits the width and height of the image to match the canvas size. This option does not pre-
serve the aspect ratio of the original image.

Preserve aspect and fit: Fits the larger image dimension to the canvas size, while preserving the 
aspect ratio of the original image.

Preserve aspect and crop: Fits the smaller image dimension to the canvas size, while preserving 
the aspect ratio of the original image.

Tile: Repeats the image horizontally and vertically to fill the canvas. This option preserves the size 
and aspect ratio of the original image.

Tile Horizontally: Fits the image height to the canvas size, then repeats the image horizontally to 
fill the canvas. This option does not preserve the aspect ration of the original image.

Tile Vertically: Fits the image width to the canvas size, then repeats the image vertically to fill the 
canvas. This option does not preserve the aspect ratio of the original image.

Pad: Centers the image on the canvas. This option preserves the aspect ratio of the original image.

Opacity - Use the slider to adjust the opacity of the background image.

Maximum cached width - Set the maximum cache width used for the background image. Larger 
cache size allows for higher-resolution images, but may have a longer load time. Smaller cache size 
may allow image to load faster, but display with a lower resolution.
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Adding images
ControlSpace Remote builder software includes an image library of sources and zones that may be used to 
create your custom control panel.

 

Source Image Library

 

Zone Image Library

To place a library image on the canvas, 

1. Follow the steps 1-3 above and drag the image icon into the canvas.
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2. In the Properties tab, navigate to the directory for the Sources and Zones folders.

Locating Sources and Zones images

3. Open one of the folders to find the available images. Library images are available in five colors.

Choosing colored images
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4. Open the folder for the color you want, select an image and click Open. The image will appear on the 
canvas.

Selected Blue Image on Canvas

NOTE: Image colors match the Skin accent colors selected in the Canvas Setup properties.

5. Re-size the image by dragging the handles on the right and bottom edges of the image frame.
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Adding text frames and labels
Using the Label graphic you can place a text field on other graphics creating labels or text strings. Labels 
can be re-sized by dragging the handles on the right and bottom edges of the frame.

Dragging a Label into the Canvas

Double-clicking the Label in the canvas or clicking the Properties tab reveals the Label properties.

Label Properties
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Label Properties are defined as follows:

X/Y – X/Y coordinates of the upper left corner of the frame.

Width/Height – width and height of the frame.

Text – text field for the label.

Align – positions the text left, right, or center.

Scale – changes the size of the text.

Color – changes the color of the text.
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Adding a Frame
Using the Frame graphic you can add a rectangular shape to your design. Frames can be re-sized by drag-
ging the handles on the right and bottom edges of the frame.

Dragging a Frame into the canvas

Double-clicking the Frame in the canvas or clicking the Properties tab reveals the Frame properties.

Frame Properties

Frame Properties are defined as follows:

X/Y – X/Y coordinates of the upper left corner of the frame.

Width/Height – width and height of the frame.
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Field Color – changes the fill color.

Border Color – changes the color of the border.

Border Width – changes the line weight of the border.

Adding a region
Using the Region graphic you can add a customizable polygon to the canvas. A Region can be linked to an 
existing control panel. Regions can be re-shaped by dragging the handles on the edges of the frame. To add 
another handle, press and hold Ctrl on your keyboard, place the cursor where you want the handle, and 
click. To remove a handle, press and hold Ctrl+Shift and click on the handle.

Dragging a Region into the canvas

Double-clicking the Region in the canvas or clicking the Properties tab reveals the Region properties.

Region Properties

- 35 -



ControlSpace® Remote Builder 2.2 User's Guide

Region Properties are defined as follows:

X/Y – X/Y coordinates of the upper left corner of the frame.

Width/Height – width and height of the region.

Field Color – changes the fill color.

Border Color – changes the color of the border.

Border Width – changes the line weight of the border.

Path – links the region to an existing control panel.
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Creating Custom Controls
Project controls listed in the tree view can be dragged into a custom panel design. The appearance of but-
tons, sliders, and drop-lists can be changed using their individual properties.

Custom Buttons
1. From the Project tab, drag a button into the canvas.

2. Using the handles on the right and bottom edges, re-size the button.

Dragging a Button into the Canvas

3. To access the button properties, double-click the button or click the Properties tab.

Viewing the Mute Button Properties
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4. Adjust the properties as desired, using the options available in the tabs:

Main Tab:

X/Y – X/Y coordinates of the upper left corner of the frame.

Width/Height – width and height of the button.

Mode – selects how the button appears: Text, Image, or Text+Image (both).

Border – when checked, places a border around the button.

Text Tab: (only active in Text and Text+Image modes)

Text – allows text entry for button labels when mute is off or on.

Images Tab: (only active in Image and Text+Image modes)

Image – specifies whether to use the default icon or a custom image.

Off – specifies image when mute is off.

On – specifies image when mute is on.

Custom Sliders
1. From the Project tab, drag a slider into the canvas.

2. Using the handles on the right and bottom edges, re-size the slider.

Dragging a Slider into the Canvas
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3. To access the slider properties, double-click the slider or click the Properties tab

Viewing the Slider Properties

4. Adjust the properties as desired:

X/Y – X/Y coordinates of the upper left corner of the frame.

Width/Height – width and height of the slider.

Max – selects the maximum value on the slider.

Min – selects the minimum value on the slider.

Vertical/Horizontal – sets the orientation of the slider as vertical or horizontal.

Units – selects dB or Percent.

Color – selects the color of the slider.

Text – allows entry of a label for the slider.

Custom Drop-lists
1. From the Project tab, drag a list into the canvas.
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2. Select the items you want in the list and click OK.

Dragging a Drop List into the Canvas

3. Using the handles on the right and bottom edges, re-size the drop-list.

- 40 -



ControlSpace® Remote Builder 2.2 User's Guide

4. To access the drop-list properties, double-click the list or click the Properties tab.

Viewing the Drop List Properties

5. Adjust the properties as desired:

X/Y – X/Y coordinates of the upper left corner of the frame.

Width/Height – width and height of the slider.

Align – positions the list Left, Center, or Right

Border – when checked, places a border around the button.
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Custom Parameter Sets
1. From the Project tab, drag a Parameter Set into the canvas.

Dragging a Parameter Set into the Canvas

2. Using the handles on the right and bottom edges, re-size the button.

3. To access the properties, double-click the button or click the Properties tab.

Viewing the Parameter Set Button Properties
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4. Adjust the properties as desired:

X/Y – X/Y coordinates of the upper left corner of the frame.

Width/Height – width and height of the button.

Mode – selects how the button appears: text, or text+image.

Border – when checked, places a border around the button.

Text – in Text Mode, allows text entry for a button label.

On/Off – in Image Mode, allows an image selection for both on/off states of the button

Custom Links
1. From the Project tab, drag a control panel from Links into the canvas.

Dragging a Link into the Canvas

2. Using the handles on the right and bottom edges, re-size the button.
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3. To access the properties, double-click the button or click the Properties tab.

Viewing the Panel Link Properties

4. Adjust the properties as desired:

X/Y – X/Y coordinates of the upper left corner of the frame.

Width/Height – width and height of the button.

Mode – selects how the button appears: text or image.

Border – when checked, places a border around the button.

Text – in Text Mode, allows text entry for a button label.

Image – in Image Mode, allows selection of an image to use on the button.

Path – links the button to an existing control panel.
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Custom Setup Button
1. From the Project tab, drag a setup button from System into the canvas.

Dragging a Setup Button into the Canvas

2. Using the handles on the right and bottom edges, re-size the button.

3. To access the properties, double-click the button or click the Properties tab.

Viewing the Button Properties
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4. Adjust the properties as desired, using the options available in the tabs:

Main Tab:

X/Y – X/Y coordinates of the upper left corner of the frame.

Width/Height – width and height of the button.

Mode - selects how the button appears: Text, Image, or Text+Image (both).

Border – when checked, places a border around the button.

Text Tab: (only active in Text and Text+Image modes)

Text – allows text entry for a button label.

Images Tab: (only active in Image and Text+Image modes)

Image – specifies whether to use the default icon or a custom image. If you choose Custom, 
browse to your desired image using the field that appears below the drop-down menu.
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Custom Remote Connection Indicator
1. From the Project tab, drag a connection indicator button from System into the canvas.

Dragging a Connection Indicator Button into the Canvas

2. Using the handles on the right and bottom edges, re-size the button.

3. To access the properties, double-click the button or click the Properties tab.

Viewing the Button Properties
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4. Adjust the properties as desired, using the options available in the tabs:

Main Tab:

X/Y – X/Y coordinates of the upper left corner of the frame.

Width/Height – width and height of the dialer.

Mode -  selects how the button appears: Text, Image, or Text+Image (both).

Border – when checked, places a border around the button.

Text Tab: (only active in Text and Text+Image modes)

Text – allows text entry for button labels when the connection is off, on, or partial.

Images Tab: (only active in Image and Text+Image modes)

Image – specifies whether to use the default icon or a custom image.

Off – specifies image when the remote connection is off.

On – specifies image when the remote connection is on.

Partial – specifies image when the remote connection is partially active.
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Custom Dialer for EX-1280C
1. From the Project tab, drag a connection indicator button from the EX-1280C > PSTN or EX-1280C > 

VoIP I/O list into the canvas.

Dragging a Dialer into the Canvas

2. Using the handles on the right and bottom edges, re-size the dialer. You may need to move the dialer 
around the canvas to locate the edges for resizing.

3. To access the properties, double-click the button or click the Properties tab.

Viewing the Dialer Properties
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4. Adjust the properties as desired, using the options available:

X/Y – X/Y coordinates of the upper left corner of the frame.

Width/Height – width and height of the button.

Primary Color – selects the primary color for the dialer display from the drop-down menu.

Secondary Color – specifies the secondary color for the dialer display. This is the color of the dialer dis-
play for incoming calls.
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Custom Toggle Channel Button for EX-1280C
1. From the Project tab, drag a Toggle Channel button from EX-1280C > Blocks > 4-ch Toggle or EX-

1280C > Blocks > 8-ch Toggle list into the canvas.

Dragging a Toggle Channel Button into the Canvas

2. Using the handles on the right and bottom edges, re-size the button.

3. To access the properties, double-click the button or click the Properties tab.

Viewing the Button Properties
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4. Adjust the properties as desired, using the options available in the tabs:

Main Tab:

X/Y – X/Y coordinates of the upper left corner of the frame.

Width/Height – width and height of the button.

Mode – selects how the button appears: Text, Image, or Text+Image (both).

Border – when checked, places a border around the button.

Channel – selects the channel to toggle.

Text Tab: (only active in Text and Text+Image modes)

Off – text entry for button label when the channel is toggled off.

On – text entry for button label when the channel is toggled on.

Images Tab: (only active in Image and Text+Image modes)

Image – specifies whether to use an icon from the drop-down menu or a custom image.

Off – specifies image when the channel is toggled off. This field is active only when Custom is selec-
ted in the Image drop-down menu.

On – specifies image when the channel is toggled on. This field is active only when Custom is selec-
ted in the Image drop-down menu.
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Custom Logic Toggle Channel Button for EX-1280C
1. From the Project tab, drag a toggle channel button from EX-1280C > Blocks > Logic Input list into 

the canvas.

Dragging a Logic Toggle Channel Button into the Canvas

2. Using the handles on the right and bottom edges, re-size the button.

3. To access the properties, double-click the button or click the Properties tab.

Viewing the Button Properties
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4. Adjust the properties as desired, using the options available in the tabs:

Main Tab:

X/Y – X/Y coordinates of the upper left corner of the frame.

Width/Height – width and height of the button.

Mode – selects how the button appears: Text, Image, or Text+Image (both).

Border – when checked, places a border around the button.

Momentary – when checked, the programmed logic is only active (ON) while the button is pressed. 
When the button is released, the logic state returns to inactive (OFF).

Text Tab: (only active in Text and Text+Image modes)

Off – text entry for button label when the channel is toggled off.

On – text entry for button label when the channel is toggled on.

Images Tab: (only active in Image and Text+Image modes)

Image – specifies whether to use an icon from the drop-down menu or a custom image.

Off – specifies image when the channel is toggled off. This field is active only when Custom is selec-
ted in the Image drop-down menu.

On – specifies image when the channel is toggled on. This field is active only when Custom is selec-
ted in the Image drop-down menu.
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Custom Logic Output Button for EX-1280C
1. From the Project tab, drag a logic output button from EX-1280C > Blocks > Logic Output list into 

the canvas.

Dragging a Logic Output Button into the Canvas

2. Using the handles on the right and bottom edges, re-size the button.

3. To access the properties, double-click the button or click the Properties tab.

Viewing the Button Properties
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4. Adjust the properties as desired, using the options available in the tabs:

Main Tab:

X/Y – X/Y coordinates of the upper left corner of the frame.

Width/Height – width and height of the dialer.

Mode -  selects how the button appears: Text, Image, or Text+Image (both).

Border – when checked, places a border around the button.

Text Tab: (only active in Text and Text+Image modes)

Off – text entry for button label when the channel is toggled off.

On – text entry for button label when the channel is toggled on.

Images Tab: (only active in Image and Text+Image modes)

Image – specifies whether to use an icon from the drop-down menu or a custom image.

Off – specifies image when the channel is toggled off. This field is active only when Custom is selec-
ted in the Image drop-down menu.

On – specifies image when the channel is toggled on. This field is active only when Custom is selec-
ted in the Image drop-down menu.

- 56 -


	Introduction
	Product Overview
	Remote Builder Window
	Menus
	File Menu
	Edit Menu
	Layout Menu
	Tools Menu
	Help Menu

	Toolbar
	Project/Properties Panel
	Control Panel Canvas

	Canvas Setup Properties
	Layout Tool
	File Types

	Creating Panels Using Templates
	Creating Control Panels
	Sending to a Mobile Device

	Creating Custom Panels
	Creating Custom Layouts
	Importing backgrounds
	Adding images
	Adding text frames and labels
	Adding a Frame
	Adding a region

	Creating Custom Controls
	Custom Buttons
	Custom Sliders
	Custom Drop-lists
	Custom Parameter Sets
	Custom Links
	Custom Setup Button
	Custom Remote Connection Indicator
	Custom Dialer for EX-1280C
	Custom Toggle Channel Button for EX-1280C
	Custom Logic Toggle Channel Button for EX-1280C
	Custom Logic Output Button for EX-1280C



